Groovy Support

The Groovy Support add-on allows Groovy to be used for ZAP scripting and to run add-ons written in Groovy.
It's bundled Groovy 2.4 (2.4.14), core and all modules.

Scripting

When you create a new script you will be given the option to use Groovy, as well as the option to choose from various Groovy templates.

Add-ons

It's recommended to depend on this add-on when creating Groovy add-ons, to reduce the overall size of the add-ons and memory used at runtime.